Bug reports

Please file your Bug reports here by including a description of what you’re experiencing along with a screenshot of the issue when possible


Please file your bug reports here by including a description of what you're experiencing along with a screenshot of the issue when possible.

We appreciate your help in making Athletica work well for all!

I've discovered a bug!

-> Using Firefox (116.0.2 ) on Manjaro Linux 5.15.125-1 AND Firefox (116.4 33723) on iOS 16.6 iPhone 12

I created a new workout by clicking on "Add session", 1 bike and a couple of S&C sessions this week. When I click / tap on the main set I get a greyed out background and a spinning thinking wheel that never goes away. Only way to get back is to refresh the page.


Let me know what other details you need to help.


Thanks @Jesse. I’ve logged that bug report.

Another bug:

I wanted to do a Bike 30/30 workout today instead of aerobic ride.

Clicked ahead to next week -> Workout wizard for a 23 load run -> Replaced with 30/30 bike workout -> Saved new workout to library -> Browsed back to today and opened the library to add a new session -> Selected the saved workout and clicked add / save -> Recovery ride gets added instead.

Deleted the workout from my library and added it again from next week. Same result when adding it to today's plan.

Screens below:

[attach]39[/attach] [attach]40[/attach]

Let me know if you need more details.


Not a bug, just an end user QOL improvement.

--> While logged in, the header containing the forum link is gone. It would be nice to have a link there for easy access.


--> When the user is presented with the forum, while logged out, it is not clear that they will need to create a new credentials using the bottom link and not the top one.


Thanks for the feedback here Jesse. We hope to integrate our forum into the app in the future.

@Jesse Hi Jesse. We cannot replicate on Firefox using our particular equipment (although might not be precisely the same as yours). Can you please check again for us and confirm?

@prof Hello Prof! Just tried a private FireFox window and am still experiencing the issue on my laptop (FF v117.0, Arch linux 1.0).

I tried my iPhone Safari browser (v16.6).

I am also experiencing the issue on my desktop computer: W11 Pro (22621.2215) with FF v117.0 and I tried MS Edge (v116.0.1938.69) just in case it was my browser extensions on FF that were messing things up.

[attach]43[/attach] [attach]44[/attach]

@Jesse thanks… we think we’ve fixed… can you try again please?

@prof Thanks for the super quick turn around! Yes, it now works and I get a pop up allowing me to edit the session details and the total time.

When I create a new VO2 workout however, I cannot create intervals. Just the total time. If I edit that VO2 session I get the same popup window allowing only total time to be edited.

I recall watching the video series where you created a VO2 session (as a coach) and then edit the intervals (added a warm up, cool down and main set). Is that functionality reserved for coaches only? And is the work around to create a coach account, add myself as the athlete and then create detailed workouts when i want different ones? (Side note, I love the pre-generated ones, I just like to have the option to create my own from time to time.)

[attach]47[/attach] [attach]48[/attach] [attach]49[/attach]


@Jesse totally get that desire. As you mention, available to coaches, but not yet available on athlete accounts. We’ll consider adding that in the future.

@Jesse we can’t replicate our end. Are you still getting this?

@prof Unable to replicate today as well. Sessions are “pasting” from the library as expected now. Will post and update if the issue returns. Thanks Prof!

The "Workout Wizard" option should be available from the Home screen list of today's workouts. You need to click on "Training Plan" on the side bar and access it from the week view.

Not sure if it is a bug. I've created a new training plan for a middle distance race (low volume) with a test week at the beginning of the plan.

The swim time trial in the new plan now consists of a 500m all-out session and a 100m all-out session to determine CSS. In earlier plans, these all-out sessions consists of a 400m AO and a 50m AO (as it is also described in the Help section within the app).

Are these new AO sessions (500m & 100m) correct?


@rene Thanks for posting Rene. Indeed a bug on my end as the template writer. I have since changed to the master and should update in the future accordingly.

@ashleyidesign Hi Ashley. You’ll note on your plan when you move sessions around so that there are no sessions remaining, a rest day automatically appears. Likewise, when you slide a session back over a rest day, the rest day disappears. Thus, no real nee

@ashleyidesign That shouldn’t be the case. Can you please provide screenshot around what you are seeing showing your inability to delete race and save plan?

@prof Was hoping it would capture my cursor as well, but the button was unclickable.