Garmin ConnectIQ Workout Reserve data field

I have downloaded and installed the ConnectIq Workout Reserve data field on my Edge 1040
Done all the steps, it asked me the login but now on my Edge it’s showing “No Profile”
Any hints?

1 Like

Ha! It hasn’t officially launched yet as we are still working out any bugs. Well done finding it :smile:

If you didn’t already watch this video, it should help.

The first time connecting can take up to 15 minutes of syncing Garmin Connect and your Edge. Just leave them next to each other in a room alone so they get to know each other better!

As you are now officially a beta tester of this new feature @valtro, please let us know how it goes.

1 Like

I wanted to download the Athletica Workout Reserve app as well but cannot find it on Garmin Connect. Is it country specific?

1 Like

It is device specific. Do you have an Edge device?

No Garmin Forerunner 955 watch

Hi @Marjaana @anilakarsu yes, unfortunately it is only viewable on the ConnectIQ app store if you have a Garmin Edge device registered and selected. I initially had my Garmin watch selected and the app doesn’t show up.

We will get to the watch for real time WR on runs and bikes, but are testing/trialing it on the bike computer first.

1 Like

That model will be targeted in the running beta. But it’s got to reach cycling beta first.

Patience Grasshopper :grin:


Try again, ensuring you update data field on your Edge to latest version 1.1.0 released today. It shouldn’t ask you to login and authorise again as you’ve completed that step. Just leave your Edge and phone turned on and close by. Listen for the tune confirming your Edge has successfully downloaded your Workout Reserve profile :grin:

As @MarkB says, not officially released to beta yet. When it is official beta there’ll be more info on how to get the most out of it.


Currently updating to 1.1.0.goes into a loop for me
Connect IQ telling me it’s updating, and then coming back to tell me I need to update
Tried uninstall and reinstall, same

I’ve noticed with Connect IQ that sometimes you need to turn the GPS off and on once the update is queued. Not specific to this data field. The update process is entirely Garmin’s regardless of which datafield.

For those of you who have managed to download and install the Workout Reserve ConnectIQ field, please can you share here how the process has gone for you and any comments, questions or suggestions. We really appreciate this. :pray:


Don’t want to be a bore but just to keep sharing about this
I had succeeded to install 1.1.0 but only through direct installation on the Edge using Edge ConnectIQ integrated function and Edge connected to my home Wifi
I had ConnectIQ app opened on my Android phone (Android updated to last version) and when it was installed ConnectIQ app on the Android popped a screen telling me I needed to access my Athletica Reserve Workout account. Clicked on “Log in” and Connect IQ App on the phone tells me that “a problem occurred” and my data field shows “no profile”. Also, left phone and Edge close to each other all night long.

Hi @valtro, you’re not being a bore at all and we really appreciate the feedback. This is why we’re only rolling out to a few users at the moment - it’s not quite ready for prime time!

@Phil is the magician who is building the app, so he may have some questions for you, but he runs on iOS. I have successfully installed on Android, so I know it is working. I would be inclined to uninstall and reinstall again and see if you can do it with the documented process. If it doesn’t work, let me know and I try that myself and take a video of the full process on Android in case you are somehow missing a step.

Thanks @MarkB
I think I have tried all possible combinations and multiple uninstall/reinstall attempts … install from Android still not working, if I install directly on my Edge as said I can do it but then 'no profile", no matter how long I leave phone and Edge close to each other
So…happy to check a video or whatever can help!

1 Like


When the running beta is released and ready for testing:
Garmin Fenix/IOS user reporting for duty :crazy_face:


@valtro Are you getting the Connect IQ login prompt on your phone? This is an iPhone image but Android will be similar I’d think.

The WR data field does initiate this part of the process, through asking Connect IQ on your paired phone to do it. However, this part is under the control of your phone and Connect IQ app at this point. The data field can’t see nor control this interaction.

@MarkB will have to help with any Android specifics.

1 Like

@Phil Yes I have that screen but when clicking on ‘Sign in’ Connect IQ app tries to open web page but does not manage to do it, page crashes immediately and I am brought back to Connect IQ App with an error message (just possible to see it below and for a second, then it disappears) saying there was a problem to connect
Also, I can’t install the data field throughout Connect IQ App on my phone, install goes in a loop of installing/queue/installing
Only possible to install directly from the Edge but then ‘no profile’

1 Like

It’ll be no profile till you login and authorise the data field. That prompt should redirect from the Connect IQ app to the default browser on your phone. Is that allowed in the permissions you’ve agreed to for Connect IQ? I can’t help with Android permission model I’m afraid.

If you are seeing the AI login page briefly then maybe your default browser is crashing. Do you have any other browsers installed that you could set as default meanwhile to see if they work? What is your default browser on your phone?

1 Like

That is going through from the Connect IQ app with the phone default Android browser, I guess, I am on a Honor 90 phone with latest Android version.
I also have Chrome installed but Connect IQ app uses phone default browser for what I am seeing
Chrome is already set as default browser anyway, but it’s not using Chrome for what I see

1 Like

Thus you are saying you briefly see the Athletica login page and then it crashes without you doing anything?

1 Like