Garmin Swim Workout Paces

My swim workouts are displaying on my Garmin 945 in time/mile instead of time/100 y. Is this a known Garmin thing or is there a way to change that? It’s a little frustrating because I have to always print out my workouts on paper so that I can see the target paces.

3 Likes

Same, also on a 945 as well. I don’t think it’s a Garmin thing because swim workouts I used to export from Trainingpeaks would display as time per 100 yd.

1 Like

Hi @rafstang and @rap,
I too use the Garmin 945 and have the same issue.
Unfortunately this seems to be a Garmin thing and is reported elsewhere in other forums fyi without a solution. We await on Garmin…

4 Likes

Seems we have a lot of 945 users :wink: … same here, but can confirm that TriDot, Motivv (I think), and Humango were able to show the pacing in the correct format, so there must be a way. For now, I mentally divide by 10 to get a rough estimate, and know that now that number is a decimal of the pace needed (i.e. 25:00/km = 2.5 minutes/100m = 2:30/100m). Hope Garmin let you know what the solution is.

3 Likes

The final post in that linked thread says this…“It looks like Training Peaks get round this by just providing the information as a note rather than as a target in the fit file.”

Maybe that would be an option here as well?

1 Like

Beat me to it, passing on the notes to the watch for each interval would be super useful even when the pacing number is right so you know if you are swimming, using paddles etc. Some of the other apps do this also.

2 Likes

In the last week or 2 the paces suddenly started showing up as minutes/100y! I think they are appearing in the notes section.
The only issue I have now is that the paces do not match what the workout calls for. For example, the workout might say to swim 550y @1:55-2:04, but my watch says 550y @1:55-1:53. The workout calls for 2200y total but the watch says 2445y. It doesn’t appear to be a yards vs meters thing since everything is in yards. It’s just different, but it’s close enough that I can work with it. I’m hoping it’s working the same for others as well. Thank you Athletica team!

3 Likes